Updated information on how to disable evil mode?

What happened?

I cannot find directions on disabling evil mode that work with the current setup. I understand that I should change the :editor field, but all directions say to do that in the main init.el and it is not there.

A global search finds mostly references to it as (when (featurep! :editor evil +everywhere)) but I can’t find where that’s set.

It’s in that form in the example config, which doesn’t seem to be loaded. Copying it to config.el or init.el doesn’t change anything.

It’s also in core-modules.el but in the doom-obsolete-modules const. Nonetheless I tried to change that too with no effect.

I ran doom sync after each of these changes.

What did you expect to happen?

The information from modules/editor/evil/README.org: Again there is no :editor evil in the init.el nor in any file obviously linked or loaded from it.

* Configuration
** Removing evil-mode
You must do two things to remove Evil:

1. Remove =:editor evil= from =~/.doom.d/init.el=,
2. Run ~doom sync~ to clean up lingering dependencies and regenerate your
   autoloads files.
3. [OPTIONAL] You may want to assign new values to ~doom-leader-alt-key~ and
   ~doom-localleader-alt-key~. These are bound to =C-c= and =C-c l= by default.

I also found a reference to a page on this help forum about it, but it 404d.

System information


Loading data dump...

You don’t need to modify anything in Doom’s source code, and the directions to disable Evil are still correct.

Your $DOOMDIR lives in ~/.config/doom or ~/.doom.d, and your doom! block lives in $DOOMDIR/init.el. The doom! block tells Doom what modules to install and in what order to load them. So:

  1. Open $DOOMDIR/init.el,
  2. Search for :editor,
  3. Find (evil +everywhere) below it (your M-x doom/info tells me it is enabled).
  4. Comment this line out (by prepending ; to the line) or delete the line altogether,
  5. Run $ doom sync on the command line,
  6. Restart Emacs.

For more information on Doom modules: doomemacs/getting_started.org at 8a27eb99bec5a955833b6d23f431c5cc39e91f7f · doomemacs/doomemacs · GitHub

Not sure what that’s about, you can find it here.

1 Like

@hlissner Oh, thank you. I was in ~/emacs.d/ and thought that was the $DOOMDIR somehow. Extremely embarrassing! Thanks again for helping me.

1 Like