Eglot mode does not trigger LSP server on Rust source files

What happened?

when I open a Rust source file, eglot mode does not trigger the LSP server (rust-analyzer).

What did you expect to happen?

When I open a Rust source file, eglot should trigger rust-analyzer. In my previous doom configuration with lsp-mode this used to work.

My init.el: :tools (lsp +eglot) and :lang (rust +lsp).

After every config.el/init.el change I run: doom sync && doom compile -p -c just to be sure.

Steps to reproduce

  1. Open a Rust source file with Doom emacs
  2. In the modeline I see that EGLOT mode is enabled
  3. rust-analyzer does not start

As a workaround, I force starting the LSP server as suggested here by adding:

;; config.el
(add-hook 'rustic-mode-local-vars-hook #'lsp!)

System information


Loading data dump...