Why is my path being shown as an ellipsis, and how do I reveal it?

What happened?

I’m adding a few packages as local repos to my packages.el. Following instructions here: https://github.com/m-fleury/isabelle-emacs/blob/dd794f715b2040a6b1c7b331b22b94719868affc/src/Tools/emacs-lsp/spacemacs_layers/isabelle/README.org#doom.

When I doom sync and doom/reload, the appearance of the first of these local paths—and just the first one—changes to omit the last few segments, replacing them with “…”. The real path is there, though; if I copy it to my clipboard I get the full path, and I can see it as expected outside of emacs. The affected path is identical to the second one, which is not affected.

I’ve tried org-reveal on it, although I’m not in org-mode, and as expected it doesn’t do anything.

What did you expect to happen?

I would like to just see the path as it is in the file, without any modifications or replacements, as I see all other paths.

Steps to reproduce

  1. Copy the bit for packages.el from https://github.com/m-fleury/isabelle-emacs/blob/dd794f715b2040a6b1c7b331b22b94719868affc/src/Tools/emacs-lsp/spacemacs_layers/isabelle/README.org#doom
  2. Update the paths as appropriate
  3. doom sync and doom/reload

System information


Loading data dump...

A redditor advised this:

(advice-add '+emacs-lisp-truncate-pin :override (lambda () ()) )

and it works! So I’d still like to understand what’s going on, but the problem’s at least solved for now.