Undo-fu install Error (From Clean Install/Initial Setup)

What happened?

First time Doom Emacs user. Running on Windows 11 with WSL. Using emacs 28.1.

On install I get a git error just for emacs-undo-fu.

> Updating recipe repos...
  > Updating packages (this may take a while)...
    x There was an unexpected runtime error
      Message: Failed to run "git"; see buffer *straight-process*
      Backtrace:
        (signal error ("Failed to run \"git\"; see buffer *straight-process*"))
        (error "Failed to run %S; see buffer %s" "git" "*straight-process*")
        (if success (let ((output (concat stdout stderr))) (if straight--process-trim (string-trim output) output)) ...
        (let* ((result (apply #'straight--process-run program args)) (exit (car result)) (invoked (numberp exit)) (s...
        (straight--process-output "git" "rev-parse" "HEAD")
        (straight-vc-git-get-commit "emacs-undo-fu")
        (apply straight-vc-git-get-commit "emacs-undo-fu")
        (let ((func (intern (format "straight-vc-%S-%S" type method)))) (if (fboundp func) nil (let ((regexp (format...
        (straight-vc get-commit git "emacs-undo-fu")
        (let ((straight--default-directory (straight--repos-dir local-repo))) (straight-vc 'get-commit type local-re...
        (straight-vc-get-commit git "emacs-undo-fu")
        (let ((ref (straight-vc-get-commit type local-repo)) (target-ref (cdr (or (assoc local-repo pinned) (assoc p...
      ! Wrote extended backtrace to ~/.emacs.d/.local/logs/cli.doom.220704104813.20366.error
    ! Script was abruptly aborted, leaving Doom in an incomplete state!
    - Run 'doom sync' to repair it.

I ran doom sync without any issues, and doom emacs starts up just fine, but I get a constant error message:

Error (doom-first-buffer-hook): Error running hook "undo-fu-mode" because: (file-missing Cannot open load file No such file or directory undo-fu) Disable showing Disable logging

Ran doom install again, doom sync, etc. a few times. Also tried doom clean && doom build && doom sync -u, but still get the same error.

It looked like someone had a similar issue with a different plugin on github, so I tried to suggested solution for undo-fu

git clone https://github.com/emacsmirror/undo-fu ~/.emacs.d/.local/straight/repos/undo-fu

Which also didn’t work. Lastly, I tried adding undo-fu as a package in the packages.el file, but that didn’t work either.

What did you expect to happen?

doom install would complete without errors, and launch without the undo-fu-mode error.

Steps to reproduce

  1. Install emacs 28.1
  2. git clone GitHub - doomemacs/doomemacs: An Emacs framework for the stubborn martian hacker ~/.emacs.d
  3. ~/.emacs.d/bin/doom install

System information


Loading data dump...

Just tried again, but on Ubuntu 22.04 and did not have any issues!

Probably an issue with the git version, or something like that.