The s and S keys don’t behave like they do in Vim/Evil

You’ll notice s and S don’t substitute the character/line like they would in vim or vanilla evil-mode. Instead you’ll see a 2> prompt in the minibuffer, and Emacs consumes to characters.

What does this mean and why does it happen?

How do I get the old functionality of s and S back?

This is intentional. These keys have been replaced by the evil-snipe plugin, which provides 2-character versions of the f/F motion keys, ala vim-seek or vim-sneak.


These keys were changed because they are redundant with cl and cc respectively (and the new behavior was deemed more useful).

To restore the old behavior, simply disable evil-snipe-mode:

;; in ~/.doom.d/config.el
(remove-hook 'doom-first-input-hook #'evil-snipe-mode)

:thought_balloon: The evil-snipe package can alternatively be disabled, but this is not recommended, because you will lose its augmentations on evil’s standard f/F/t/T motions.