Solved: Sidebars open in complete frame (was: treemacs opens in complete frame)

What happened?

When I open treemacs it opens in full screen. When I tried neotree before it said “cannot resize the root window of a frame”

What did you expect to happen?

treemacs opens in a side bar

What did I troubleshoot?

  1. I tried neotree and treemacs and both have sidebar issues
  2. I ran doom upgrade
  3. I ran doom clean && doom build && doom sync -u
  4. I tried the sandbox.
(require 'treemacs)
(find-file "~/dotfiles/doom/.doom.d/")
  • vanilla emacs: it works
  • doom emacs core: I get
Debugger entered--Lisp error: (void-function doom-initialize)
  (let ((doom-init-modules-p t)) (doom-initialize) (doom-initialize-core-modules))
  load-with-code-conversion("/tmp/doom-sandbox/init.el" "/tmp/doom-sandbox/init.el" nil t)
  command-line-1(("-l" "/tmp/doom-sandbox/init.el"))

The same for Doom + modules - private config Doom + modules + private config brings up my problem

System information

Loading data dump...

So, neotree brings the error cannot resize the root window of a frame and I get an empty window that has the size of a frame.

Now I just tried the package “dired-sidebar”. When I use dired-sidebar-show-sidebar and dired-sidebar-hide-sidebar everything works as expected. But when I use dired-sidebar-toggle-sidebar I have a similar problem. dired-sidebar opens twice - in a sidebar and in the window with the current file.

After removing .config/emacs and re-installing doom everything works as expected