Search for symbol in current workspace

Hi,

I am not able to search for a symbol in my workspace. I don’t know if this is possible in Doom Emacs. I’ve just switched from Sublime Text, in Sublime I used to do Ctrl+Shift+R and type somehting like “aciton_” and it would do a fuzzy search on my current project. I’ve installed Doom Emacs and configure it, I do most of my work in php so I have something like (php +lsp +tree-sitter) in my config.el. When I open a php project, intelephense starts and I get error checking, so it seems to be working fine. I don’t know exactly how it works, but I can also see all symbols from a file by opening treemacs buffer and pressing tab on a file. But when I try to search for a symbol project wide nothing happens. I try SPC c j and a buffer with the text “0 LSP Symbols #” appears. I try to type something like “action_” and now I have “0 LSP Symbols #action_” (I’ve also tried 0 LSP Symbols action_) but that’s all that I see. I’ve tried this on php, javascript and c projects and it’s not workings for any of them. What can I do?

I’ve also asked this question on discord.

Update: this being a search related issue, I’ve commented out one line of my init.el (ivy +fuzzy +prescient) and now I can search for symbols, but can someone please explain what happend? I also have company and vertico enabled. That ivy form was there because I wanted to do fuzzy search on files. I’ve took it from here and now I can’t do fuzzy search on file names anymore. How can I fix it?

The Vertico and Ivy modules are alternatives and aren’t really designed to be enabled together.

You can configure completion-styles to enable fuzzy completion. flex comes with emacs, or there are third-party packages like GitHub - axelf4/hotfuzz: 🚓 Fuzzy Emacs completion style. Or you can just rely on the included orderless style and separate your queries by spaces when you want them to be fuzzy (i.e. b a r will match filenames containing those characters in any order).