Pyright isn't recognized, and failes to install


I’m trying to set up lsp-pyright, and I’m having some difficulties… when openning a .py file emacs says it can’t find a language server for it, so it suggests to install pyright, but fails to do so because it can’t find npm.

I’ve manually installed node and npm - which didn’t solve the problem - so I went ahead and manually installed pyright, but emacs still doesn’t recognise it exists when I open a .py file…

I’m on windows, if that matters.

Any ideas? Thanks!

Hi! I’m not a windows user, but usually these things happen because of PATH issues. Can you run pyright from anywhere in your system? I mean can you open a terminal and run “pyright” without specifying any path to it? If that will not work - you probably installed pyright wrong. You can then try to install pyright via pip (less options to do the wrong thing) pip install pyright

Thanks! I’ve just been able to make it work, and you’re eight that it was in fact a PATH issue. I had to call doom env to regennerate the envvar files, and that solved it.

Glad it worked out! :grinning:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.