Projectile commands fail with `Invalid version syntax: 'No'` error


I know Emacs 29 isn’t supported, but I’m forced to use Wayland, so I really need pgtk, with pixel-scroll-precision-mode being a cherry on top :slight_smile:

Initially I wanted to open an issue, but I think this is the place where questions about development versions may be asked.

What happened?

At least some Projectile commands (e.g. projectile-find-file, projectile-switch-project, but NOT projectile-add-known-project) fail with Invalid version syntax: `No'.

Full relevant *Messages* output:

Loading data dump...


Loading data dump...

What did you expect to happen?

Not to fail

What I tried

  • searched the Internet and found a similar issue, followed the advice, and my cmake --version returned valid cmake version 3.22.1. At the end the above issue came out as Windows-related.
  • doom clean, doom build, remove the .local dir, reinstall Doom
  • searched Doom issue tracker and Discourse
  • read FAQ
  • searched Projectile issue tracker
  • enabled doom-debug-mode - it couldn’t capture backtrace
  • tried sandboxes:
    • vanilla Emacs - no Projectile obviously
    • vanilla Doom, Doom + modules - my private config:
    Loading data dump...
    • Doom + modules + my private config: it should be the same as the main instance, but it actually allowed my to capture the backtrace with doom-debug-mode!

Steps to reproduce

  1. Add any project (tried both with and without any vcs repo initialized)
  2. projectile-find-file

System information

Loading data dump...

What does fd --version output, in the shell?

Try updating Doom. The following change should prevent issues like these:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.