Problems after upgrading

What happened?

After upgrading to revision 7a75030458 modeline characters don’t appear correctly. Either they appear too small or the character doesn’t appear at all.

The major mode icon:

Screenshot from 2023-08-22 10-20-19

The LSP and errors icons:

Screenshot from 2023-08-22 10-21-38

I also get this warning in *messages*:

.config/emacs/.local/straight/build-29.1/lsp-mode/lsp-mode.el: Warning: Non-symbol arguments to cl-defgeneric: (process process)

What did you expect to happen?

I would expect everything to work normally.

System information

Loading data dump...
1 Like

For the doom-modeline icons, we have to install nerd fonts with M-x nerd-icons-install-fonts and restart Emacs.

See also: doom-modeline now uses nerdfonts · Issue #7368 · doomemacs/doomemacs · GitHub

(Or, if that’s not working, as a last resort add

(package! doom-modeline :pin "6125309c2caa")

to packages.el and doom sync -u. This reverts the doom-modeline pin to the version it was before 7a5f5d07e72d496ff614e0892c78b62b31aaac4d.)

1 Like

Thanks that fixed it (for now at least…)

Added a better solution now. Remember that if you remove the pin in packages.el, you have to doom sync -u again.

Tried your new solution and works too, but… I much prefer the old look of all-the-icons.

Well, I suppose I’ll have to get used to it.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.