Leader key (SPC) doesn't work on Manjaro, same configs work on macOS

What happened?

When I run Emacs with doom on Manjaro, SPC is not defined as the leader key (apparently), despite the same ~/.config/doom/*.el files working on macOS on two other computers. Pressing SPC just gets a message ‘End of line’ in the minibuffer.

image

I also notice the modeline has a single ‘1’ at the left, and nothing else.

What did you expect to happen?

Work as normal.

Steps to reproduce

  1. Install Emacs 28.1-7 using Manjaro’s package manager.
  2. git clone https://github.com/doomemacs/doomemacs ~/.config/emacs
  3. git clone my config files to ~/.config/doom
  4. Added ~/.config/emacs/bin to path
  5. doom install
  6. sudo pacman -S emacs-nativecomp and remove plain emacs due to warning (shouldn’t matter)
  7. doom doctor and install everything Emacs wants.

Grateful for any help!

System information


Loading data dump...

If you ever find that keybindings are missing, this is an indicator an error has occurred at startup. Check the *Messages* buffer for warnings or errors, and produce a backtrace from the error, if you can.

I’m on manjaro and it works for me.

The message buffer can be opened after startup, the function to open it is called view-echo-area-messages

If you can’t find it you can also just try a fresh install. Make sure you have all the prerequisites installed, I recommend the native compiled emacs, how to install it is described really good in the doom emacs github image

https://www.emacswiki.org/emacs/GccEmacs

once you installed emacs you run

git clone --depth 1 https://github.com/doomemacs/doomemacs ~/.emacs.d

~/.emacs.d/bin/doom install

and this should be all, worked like a charm on my manjaro instance

here is the doom github for reference:

Missing fonts. Who would have thunk it?

Thanks @hlissner and @Riccardo_Varenna !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.