How to investigate: emacs/doom suddenly stopped working: just blank screen forever?

What happened?

My emacs/doom suddenly stopped working. It never finishes its start-up, just a blank screen, when I execute ‘~/doom-emacs-dec-17/bin/doom run’.

It was working earlier yesterday, but then the above problem happened.

It seems that my emacs/doom behaviors may have been deteriorating in the last couple of days. It started when org-journal-new-entry never returned. I had to C-g (abort) it yesterday (12/16). But after more trials, it gets even worse.

What did you expect to happen?

I expect it to finish the start-up, and to be responsive for subsequent interaction.

Steps to reproduce

  1. Cloned the latest configuration of doom on 12/17/2022 (today).

  2. I tried to perform ‘doom sync -u’ and ‘doom build’, but the problem remains.

  3. If I try ‘emacs -q’, I have no problem getting the emacs without my configuration started.

  4. I also tried emacs28, and emacs28-native, and the behavior of the problem is the same.

  5. Running ‘~/doom-emacs-dec-17/bin/doom doctor’ there is no apparent problem:

Loading data dump...

System information

Loading data dump...

This topic was automatically closed after 360 days. New replies are no longer allowed.