Format onsave not working for Julia

What happened?

I recently updated my doom emacs to v3.0.0-pre. While most stuff worked out of the box I noticed that the formatting on save for Julia was not working. When I called the +format/buffer, it was formatting the buffer but not when saving. I tried different approaches, but in vein. There exists FelipeLema/julia-formatter.el: Use JuliaFormatter.jl as backend for indenting code - which also works when invoked but is not being used by the lsp to format on save, neither by the editor.

If I understood correctly, there are two options to format onsave, one is done by the editor and the latter is by the lsp. In my previous doom version, I was able to use julia-formatter on save, since I use a dot-file for the preferences.

What should I do, to use julia-formatter for onsave formatting?

What did you expect to happen?

Expected behaviour: formatted buffer after saving.

Steps to reproduce

  1. Install v3.0.0-pre.
  2. install (julia +onsave)
  3. write some julia code and save

System information

Loading data dump...