Font Icons are messed up

What happened?

All of the font icons (in doom modeline, treemacs, etc) are screwed up. They are either the wrong icon, or an error icon. I’m not sure why.

What I tried:

~/.local/share/fonts contains all-the-icons.ttf, file-icons.ttf, fontawesome.ttf, material-design-icons.ttf, octicons.ttf, and weathericons.ttf.

I tried cloning all-the-icons and copying all of the .ttf files into ~/.local/share/fonts, but the result was the same.

I tried running M-x all-the-icons-install-fonts

I tried rebuilding doom and repeating all of the above.

Nothing ever changed

Note: the issue is happening on the Dell XPS 9530. I just upgraded from the Dell XPS9510 which has an IDENTICAL config (both doom emacs and overall system configuration), and the icons load perfectly on there.

Output of pacman -Q | grep ttf:

ttf-all-the-icons 5.0.0-1
ttf-carlito 20230509-1
ttf-dejavu 2.37+18+g9b5d1b2f-4
ttf-font-awesome 6.4.2-1
ttf-iosevka 27.2.0-1
ttf-liberation 2.1.5-1
ttf-ubuntu-font-family 1:0.83-1
ttf-weather-icons 2.0.12-1

System information

Loading data dump...

Doom switch fonts recently. Try running nerd-icons-install-fonts.

Wow that worked. Thanks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.