Font changes when Emacs window loses focus

Already asked in Discord but it’s quite complex to describe, so :crossed_fingers: I have more luck over here:

What happened?

When using Emacs with UI under Linux, the font face of certain elements will change from my default doom-font to a different font. Here is a video of the effect in action when an org-agenda entry becomes overdue:


(Watch the Test-Entry, especially the letter r changing its font family) This will only happen if the Emacs window is in focus.

What did you expect to happen?

I would expect to find the font face that’s used to style those fonts and be able to change it to the default font, so it does not wobble when the Emacs window loses it’s focus.

I already changed all the fonts

  • doom-font
  • doom-variable-pitch-font
  • doom-serif-font
  • doom-unicode-font

to the same font, but this doesn’t help. I also tried to change themes, but the issue also affects doom-one-light or doom-one. I also tried toggling solair-mode to no effect. :frowning:

Any hints on where this could come from?

System information

Loading data dump...

I’ve seen this before as well. Does Fix font fallbacks by hpfr · Pull Request #7448 · doomemacs/doomemacs · GitHub help?

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.