`doom run` works, but `emacs` loads doom but has troubles with tex-site

What happened?

After including

(package! polymode)
(package! poly-markdown)

in packages.el

If I run doom, by running emacs, and do doom/reload I get the following

Warning (initialization): An error occurred while loading ‘/home/bruno/.config/emacs/.local/etc/@/init.28.elc’:

File is missing: Cannot open load file, No such file or directory, tex-site

To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the ‘--debug-init’ option to view a complete error backtrace. Disable showing Disable logging

And (obviously) poly-mode is not working and Rmd files don’t get into the Markdown mode.

The strange thing (for me) is that everything works perfectly when I use doom run.

One thing I did, not sure if it was related is to add alias emacs=“emacsclient -c -a ‘emacs’” to the .bashrc (in Ubuntu), because without it wasn’t recognizing doom when I used emacs from “open with”

I clearly have a problem with how emacs is being run (see below), but I have no idea how to solve it.

System information

From doom run

Loading data dump...

From emacs:

Loading data dump...