Docstr does not work with doom

What happened?

When trying to use docstr, the plugin is disabled whenever I load it using M-x docstr-mode. Another thing is that it reloads lsp-mode (I have not seen the plugin’s code, so I don’t know if it makes irregular changes when loaded). Also, I tried as @jjohnstone suggested (advice-remove 'newline-and-indent #'+default--newline-indent-and-continue-comments-a) but it did not work.

What did you expect to happen?

When creating a comment, e.g., above a function with some arguments, it should make a comment with the arguments of the function to fill the comments for them.

Steps to reproduce

  1. Add docstr in packages.el
  2. Load it for the language you prefer.
  3. Create a comment above a function and press enter inside it. It should create a templated comment with the function’s parameters (but it does not).

System information

Loading data dump...

Solved check docstr issue

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.