Can't get menu-bar displayed on startup

I can’t get the menu-bar displayed on startup. I’m running emacs 28.2 on Windows 11.

I can M-x menu-bar-mode after startup and it displays just fine.

I’ve tried the following in my config.el:

(after! core-ui (menu-bar-mode 1))

(after! core-ui (menu-bar-mode t))

(menu-bar-mode 1)

(menu-bar-mode t)

I cannot reproduce that. (menu-bar-mode +1) in $DOOMDIR/config.el works for me. Please include your M-x doom/info, and ensure that Doom is up-to-date.

core-ui was renamed to doom-ui, by the way, but it shouldn’t make a difference either way. doom-ui is always loaded before $DOOMDIR/config.el is.

Thanks for answering so quickly! I did a doom sync (no change). FYI, I’ll try this on my work machine tomorrow (also Windows 11)

Here’s my doom info. Also, (menu-bar-mode +1) is the only customization in my config.el

C:\Users\lel48\.emacs.d\bin>doom info
generated  Sep 18, 2022 16:07:46
system     Windows Unknown
emacs      28.2 ~/.emacs.d/ -> ~/.emacs.d/
doom       3.0.0-pre PROFILE=_@0 HEAD -> master 811c18ca6 2022-09-16 19:20:45
           +0200 ~/.doom.d/ -> ~/.doom.d/
shell      c:/tools/emacs/libexec/emacs/28.2/x86_64-w64-mingw32/cmdproxy.exe
features   ACL GIF GMP GNUTLS HARFBUZZ JPEG JSON LCMS2 LIBXML2 MODULES
           NATIVE_COMP NOTIFY W32NOTIFY PDUMPER PNG RSVG SOUND THREADS TIFF
           TOOLKIT_SCROLL_BARS XPM ZLIB
traits     batch server-running custom-file
modules    :completion company vertico :ui doom doom-dashboard hl-todo modeline
           ophints (popup +defaults) (treemacs +lsp) (vc-gutter +pretty)
           vi-tilde-fringe workspaces :editor (evil +everywhere) file-templates
           fold snippets :emacs dired electric undo vc :checkers syntax :tools
           (eval +overlay) lookup lsp magit :lang (cc +lsp) clojure emacs-lisp
           markdown org sh :config (default +bindings +smartparens)

C:\Users\lel48\.emacs.d\bin>
;;
;; You can also try 'gd' (or 'C-c c d') to jump to their definition and see how
;; they are implemented.

(menu-bar-mode +1)

Problem solved…

I don’t recall doing this (and we’re talking about an install I did yesterday), but here is my custom.el:

(put 'projectile-ripgrep 'disabled nil)
(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(menu-bar-mode nil))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )