2 emacs processes running for one doom emacs instance running . Is that normal?

When I run doom emacs,I have 2 “emacs” processes running and one “sh” process . When I run emacs, I have only one emacs process.

Emacs server is not started.

Is that a normal behavior to have 2 “emacs” processes when one instance of Doom emacs is running ?

What did you expect to happen?

I might be wrong but shouldn’t we have only one “emacs” process running when doom emacs is started ?

Steps to reproduce

  1. doom emacs &
  2. Check how many emacs processes are running

System information

generated Mar 07, 2024 22:02:17 system Linux Mint 21.3 Linux 5.15.0-97-generic x86_64 emacs 29.2 EMACSDIR=~/.config/emacs/ EMACS=/usr/local/bin/emacs doom 3.0.0-pre PROFILE=_@0 grafted, HEAD → master, origin/master, origin/HEAD bea8127 2024-03-05 01:21:09 -0500 ~/.config/doom/ shell /usr/bin/zsh features CAIRO DBUS FREETYPE GIF GLIB GMP GNUTLS GSETTINGS HARFBUZZ IMAGEMAGICK JPEG JSON LCMS2 LIBSELINUX LIBXML2 MODULES NATIVE_COMP NOTIFY INOTIFY PDUMPER PNG RSVG SECCOMP SOUND THREADS TIFF TOOLKIT_SCROLL_BARS X11 XAW3D XDBE XIM XINPUT2 XPM LUCID ZLIB traits batch envvar-file modules :config use-package :completion company vertico :ui doom doom-dashboard hl-todo modeline ophints (popup +defaults) (vc-gutter +pretty) vi-tilde-fringe workspaces :editor (evil +everywhere) file-templates fold snippets :emacs dired electric undo vc :checkers syntax :tools (eval +overlay) lookup magit :lang emacs-lisp markdown org sh :config (default +bindings +smartparens)

This topic was automatically closed after 90 days. New replies are no longer allowed.